::: Virtual Aleph ::: Virtualization Techniques: KB Article: esxupdate Fails with Package Downgrade Warning

VMworld 2016 Banner

VMworld 2016 Banner
VMworld 2016 Barcelona

30 May, 2007

KB Article: esxupdate Fails with Package Downgrade Warning

From VmWare Knowledge Base:

Details
The patch maintenance tool, esxupdate, was created to allow the installation of patches in random order. However, a flaw prevents the installation of older patches after newer patches (with an updated, overlapping RPM) is installed. In this situation, esxupdate returns the following messages, which indicate the bundle contains a package that has an older revision than what is already installed on the system:

INFO: 1 packages need to be downgraded.

Please use the --force option and try again.

Solution

Read the KB for solution